5 Replies Latest reply: May 15, 2014 9:51 AM by Data Kruncher RSS

    first row contains column titles problem

    Joel Heyman

      I am having a problem with a csv file.  The csv file does not have column titles.  Every time i open the csv file in monarch with the model, the check box is checked for "First row contains column titles".  I would think that by using a model it should save the setting that the first row does not contain column titles.  I have Monarch Pro v 8.02.  Is this a bug?  Has anyone else seen this?  Any workarounds?

        • first row contains column titles problem
          Grant Perkins

          Joel,

           

          Your observation prompted me to do a little testing and my test file offers the same behaviour as you have found.

           

          Also, if I save the database/model to a project no data loads (though it reports 412 rows!) under the column heading (which is a system allocated field name F1) when I open the Project.

           

          If I save the model with the 'First Row' box ticked it works fine.

           

          I would conclude that there is a bit of a problem somewhere.

           

          I too am using 8.02.

           

           

          Grant

           

          PS - Workaround?

           

          The only thing I can think of at the moment is to add a line to the top of of the file each time you process it. If you had a single row 'cloumn names' file you could concatenate you main file to it and then process the result.

           

          Would that be any help?

          • first row contains column titles problem
            Gareth Horton

            Joel

             

            This is a bug.  It was introduced in 8.02 unfortunately and it is due to Monarch not saving the setting correctly in the model.

             

            This did not affect 8.01, so if you open the model in 8.00/8.01 and resave it, then it will work fine when you process it with 8.02.

             

            It is likely we will have a hotfix for this, rather than a whole new version, as it will only affect a limited number of users.

             

            I will also post some instructions on how to change this within the xmod.

             

            I will keep you informed on the status.

             

            Gareth

             

            Originally posted by Joel Heyman:

            I am having a problem with a csv file.  The csv file does not have column titles.  Every time i open the csv file in monarch with the model, the check box is checked for "First row contains column titles".  I would think that by using a model it should save the setting that the first row does not contain column titles.  I have Monarch Pro v 8.02.  Is this a bug?  Has anyone else seen this?  Any workarounds? /b[/quote]

            • first row contains column titles problem
              Gareth Horton

              Joel,

               

              To get the 8.02a hotfix call Monarch technical support at 978-441-2200, or click on the following  [url="http://www.datawatch.com/forms/dsp_tech_support.asp"]link[/url] to submit a call ticket requesting Monarch v8.02a

               

              Gareth

               

              Originally posted by Gareth Horton:

              Joel

               

              This is a bug.  It was introduced in 8.02 unfortunately and it is due to Monarch not saving the setting correctly in the model.

               

              This did not affect 8.01, so if you open the model in 8.00/8.01 and resave it, then it will work fine when you process it with 8.02.

               

              It is likely we will have a hotfix for this, rather than a whole new version, as it will only affect a limited number of users.

               

              I will also post some instructions on how to change this within the xmod.

               

              I will keep you informed on the status.

               

              Gareth

               

                /size[quote]quote:[/size]Originally posted by Joel Heyman:

              I am having a problem with a csv file.  The csv file does not have column titles.  Every time i open the csv file in monarch with the model, the check box is checked for "First row contains column titles".  I would think that by using a model it should save the setting that the first row does not contain column titles.  I have Monarch Pro v 8.02.  Is this a bug?  Has anyone else seen this?  Any workarounds? /b[/quote][/b][/size][/QUOTE]

              • first row contains column titles problem
                Eric A

                I am using Monarch Pro Ver 9.00 

                I notice this is a pretty old thread but this is the exact problem I am having.  The link is gone.  If the instructions are out in the forumomewhere, I can't find it.  could you please re post the instructions o the workaround for me.