1 Reply Latest reply: May 15, 2014 10:12 AM by offpiste.reese _ RSS

    Monarch 11 COM Object

    offpiste.reese _

      I am writing a C# app that will automate Monarch.  I installed Monarch 11 on a machine with Monarch 5 by accident, I forgot Monarch 5 was there.  Anyhow, I was writing the c# app and realized it was starting Monarch 5, not 11.  I uninstalled 5, restarted the computer, started up Monarch, closed it and then tried to run my app again.  Same result.  I am getting an error that indicates the Monarch 11 COM object isn't installed/registered.  When I run the code below, I get an error on the CreateInstance call because the return from GetTypeFromProgId is null.


                  object monarch;

                  object[] Param1 = new object[2];


                  Type objClassType;

                  objClassType = Type.GetTypeFromProgID("Monarch32");

                  monarch = Activator.CreateInstance(objClassType);


      Do I need to reinstall Monarch?  Can anyone tell me what DLL I need to register?  Any thoughts are appreciated.